gvm-init.sh permission denied

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

gvm-init.sh permission denied

rileyvanzeeland
Hey, so I'm what you would call a noob when it comes to the linux environment. Coming from a windows background my whole life and having little to no experience in linux and it's friendly environments. :)

My problem is that I'm trying to install gvm on my Fedora 20 and have followed the directions on github but have come across a small problem I can't figure out how to solve. Gvm appears to install and give me the option to restart my terminal or to run the shell file gvm-init.sh in my .gvm/bin directory. When I restart the gvm command 'is not found', so I have un-installed and re-installed and restarted my computer. No luck. So I tried to install but then run gvm-init.sh but I get permission denied (while accessing it as a root user (su)). I can open the file in 'vi' but I wouldn't know what to do to give myself the ability to run it. :(

I did find someone with a similar problem, after a long term searching but he simply said " remove the immutable bit" then "make your changes" and the guy responded with "I modifyed my script so they take care about this issue. Now things look okay" But I dont' know how nor could I figure out how to do this. :( Also, there is no 'i' in the listing of permissions? So I'm not sure if this is going to help me.

This is the file-

-rw-rw-r--.  1 riley riley 6848 Dec  5 14:38 gvm-init.sh

Any ideas?
Reply | Threaded
Open this post in threaded view
|

Re: gvm-init.sh permission denied

rileyvanzeeland
Actually, scrap that, I found the problem. The file Didn't have 'execute' box ticked to allow the file to be executed as a program. Then the gvm-init.sh file was looking for files in /root/.gvm  because $HOME was set to /root/ changed the shell file to look for the files in 'my home' directory and it works. :)

The first part seems so simple now but didn't see the option last time I looked.
Reply | Threaded
Open this post in threaded view
|

Re: gvm-init.sh permission denied

marco.vermeulen
Administrator
Not sure if I understand your problem. Did you try installing GVM for developing on GVM, or do simply want to use it?

The instructions on Github are for people who want to develop on GVM, where the instructions on http://gvmtool.net are the simple instructions that a user should follow. It's as simple as typing:

curl -s get.gvmtool.net | bash

After that, close your terminal and open a new one and GVM is ready to use!

Cheers,
Marco.
---
Marco Vermeulen